Search Google Appliance

Information Technology

Action required for systems running Windows 7, XP, 2003, & several Microsoft server operating systems

May 16, 2019

For university-owned computer, please contact the IT support specialist in your department if applicable. On Wednesday, May 15, 2019, Microsoft released a patch for a critical Remote Desktop flaw that affects Windows 7 as well as several server operating systems (Server 2008, Server 2008R2, and Server 2003). Because of the high severity of this flaw, Microsoft is also issuing patches for Windows XP and Windows 2003. 

Microsoft recommends installing these patches as soon as possible because exploits against this vulnerability could be made into a self-propagating worm

For university-owned computer, please contact the IT support specialist in your department if applicable. 

IT Administrators are asked to apply the patch right away and to also upgrade any systems running XP or 2003 to IT-supported operating systems wherever possible.

End users are asked to reboot their computer(s) when prompted to complete the patch process.