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Manipulating Query Data in Excel 
 
Introduction 
 
The purpose of this guide is to highlight a few of the most common techniques for 
manipulating data that you have downloaded from a Human Resources or Finance system 
query into an Excel worksheet.  The Excel features covered include: 

• Saving the query data 
• Formatting 
• Inserting title rows 
• Centering a title 
• Wrapping column headings 
• Freezing column and row headings 
• Sorting 
• Calculating totals 
• Subtotals  
• Filtering 
• Using the Excel List feature (Excel 2003 only) 
• Comments 
• Entering data in multiple worksheets at once 
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Save Your Query Data 
If you simply click on the Save button in Excel, you will be saving your document to the 
server in Shrewsbury.  To save your file to a folder on your local hard drive: 

• Select File > Save As… from the menu.  
• Click on the down arrow in Save in: box to display a list of drives and folders 

(See Figure 1 below).  Note that the local drives associated with your computer 
will be listed in the format:  C$ on ‘Client’ (C:) 

• Click on the local drive on which you want to save the file. 
• Create or select the folder in which you want to save the file. 
• In the File name box, enter a name for the query. 
• Click on Save. 

 
. 

 
Figure 1 

 
Format Data 
You may need to re-format columns containing numbers.  For example, you may want to 
increase or decrease the number of decimal places in a dollar amount or, because the 
usual default cell format eliminates leading zeroes, you will need to change the 
formatting in order to display the three leading zeroes in a purchase order number. 
 
To change the cell format: 
• Select the cell, cell range or column to be changed. 
• From the Format menu select Cell, then Number. 
• Select the Category. 
• Enter or select the desired options. 
• Click OK. 
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Example 1: 
To ensure the appearance of leading zeroes in a 10-digit purchase order number: 
• Select the cells to be re-formatted. 
• From the Format menu select Cell, then Number. 
• Under Category, select Custom. 
• Under Type enter 10 zeroes (0000000000). 
• Click OK. 
 
Example 2: 
To format a dollar amount with two decimal places, a dollar sign and thousandths 
indicator: 
• Select the cells to be re-formatted. 
• From the Format menu select Cell, then Number. 
• Under Category, select Currency. 
• View the sample to make sure that the default formatting includes a dollar sign, 

commas, and two decimal places; otherwise, select the appropriate format. 
• Click OK. 
 
Insert Title Rows 
To insert one or more rows of descriptive title information above your data: 
• Select the row headings (numbers at the far left of the worksheet) of as many rows as 

you wish to insert. 
• Right-click and select Insert.  Your new row(s) will be inserted above the row 

containing the column headings. 
 
Center a Title 
To center a title across the columns of your worksheet: 
• Select the columns 
• Click on the Merge and Center button in the Formatting toolbar 
 OR 
• From the Format menu, select Cells, then Alignment. 
• Under Text Alignment-Horizontal, select Center across Selection from the drop-

down menu. 
• Click OK. 
 
Wrap Column Headings 
In order to manipulate your data, your column headings must occupy only one row.  To 
fit more text in the heading, change the cell formatting to allow your text to wrap around.  
The height of the heading row will automatically increase to accommodate the text. 
• Select the heading cells. 
• From the Format menu, select Cells, then Alignment. 
• Click in the Wrap Text check box. 
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• Click OK. 



Freeze Column Headings 
When you have a large worksheet, it is helpful to keep the column headings displayed at 
the top of your screen as you scroll through the rows of data.  To freeze your column 
headings: 

• Click in the row heading (row number to the left of the first column) of the row 
immediately below the row of headings (See Figure 2).  The entire row will be 
selected. 

• Click Window>Freeze Panes 
• To undo this action, click Window>Unfreeze Panes. 

 
 
 

 
Figure 2 

 
Freeze Row Headings 

• Click in the column heading to the right of the column you wish to freeze. 
• Click Window>Freeze Panes 
• To undo this action, click Window>Unfreeze Panes. 

 
Freeze Both Row and Column Headings 

• Click the cell below the row containing the column headings and to the right of 
the column containing the row headings. 

• Click Window>Freeze Panes 
• To undo this action, click Window>Unfreeze Panes 
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Click here 



Sort 
The Excel Sort function allows you to sort by three columns of data at once.  For 
example, if your worksheet contains name, department and college data, you could, in 
one step, sort your data by name, within department, within college.  If you need to sort 
by more than three columns, you sort by the first three columns, then sort again by the 
next columns. 
  
In order for the Sort function to work properly:  

• Your worksheet should have a single row of column headings across the top.  If 
necessary, you can wrap text in the heading cells by selecting 
Format>Cells>Alignment.  Click on Wrap Text, then click on OK. 

• There should be no blank rows within the data you plan to sort, although you 
may have blank cells. 

 
To sort: 

• Click in any cell within the rows of data you wish to sort. 
• Click on Tools >Sort  The Sort dialog box will appear (see Figure 3): 

 

 
 Figure 3 
 

• In the Sort by field, click on the down arrow to display your column headings and 
select the first level of your sort.  (For example, College).  Note:  if you have no 
column headings, you will see Column A, Column B, and so on. 

 
• If you want to sort by a second field, in the Then by field, click on the down 

arrow to display your column headings and select the second level of your sort. 
(For example, Department) 
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• If you want to sort by a third field, in the Then by field, click on the down arrow 
to display your column headings and select the third level of your sort. (For 
example, Name) 

 
Note:  the second and third sort levels are optional and may be left blank. 

 
• For each sort field, select Ascending or Descending.  Ascending means that 

alphabetic data will be sorted from A (at the top) to Z; and numeric data will be 
sorted starting with the lowest values at the top.  Descending means that 
alphabetic data will be sorted from Z to A and numeric data will be sorted with 
the highest values at the top. 

 
• Header Row should be selected if the first row of the data you are sorting 

contains column headings.  Usually Excel figures this out. 
 

• Click on OK. 
 
Sum 
The SUM function in Excel will provide a total of selected cells containing numerical 
data.   

• Click in the cell in which you want the total to appear. 
• Enter: =SUM( 
• Use your mouse to select the cells you wish to total or enter the range of cells 

followed by the close parenthesis.  For example, to obtain in cell D20 the sum of 
the values in cells A1 through A12, click on D20 and enter:  =SUM(A1:A12) 

 
Hint:  All functions in Excel begin with = and must contain matching pairs of 
parentheses. 
 

 AutoSum 
When you wish to total all the values in a column or row and place the total below or 
after the last value: 

• Click in the cell where you want the total to appear. 
• Click on the AUTOSUM button  in the toolbar:   
• Verify that the correct cells have been selected. 
• Press Enter. 

 
Filter 
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The filtering function allows you to view a subset of your data without making any 
permanent change to the worksheet.  The AutoFilter function is easy to use and 
sufficient for most purposes.  For example, if you wanted to view only female students 
who live in Massachusetts, you could use both the Sex and State columns of your 
worksheet to filter out only the records that meet both of these criteria.  The custom 
filtering option allows you to specify more complex criteria. 



 
Note:  If you need to filter the data in a more complex way and to place the results in a 
new location, use the Advanced Filter function (Data Filter/Advanced Filter, not covered 
in this document). 
 

• Be sure that there are no blank rows in your data. 
• Click on any cell within your data table. 
• Click on Data>Filter>AutoFilter  A box containing a down arrow will appear in 

the lower right corner of every cell in your row of column headings. 
• Click on the arrow in the column you wish to filter.  A drop-down menu will 

contain a list of each value in the column, plus the following options:  All, Top 10 
and Custom.  If there are blank cells in the column, you will also see the menu 
options Blank and Non-Blank.  In addition, you have the options of sorting the 
column of data in either ascending or descending other. 

• You may filter on any number of columns, but, unless you choose the “Custom” 
option, an “and” relationship is assumed among the filtering criteria.  

• For a wider range of filtering criteria, select the Custom option in the AutoFilter 
drop-down menu 

• To re-display all the data in a column you have filtered, click on Data/Filter/Show 
All. 

• To turn off the filtering and re-display all of the rows of data, click on 
Data/Filter/AutoFilter. 

 
 
Excel List (Excel 2003 Only) 
If you are using Excel 2003, the List command allows you to perform the sorting and 
filtering features described above even more quickly. 
 
In Excel a “list” is a set of rows and columns of data with: 
• A single header row containing the column headings 
• No blank rows within the set of data rows, although individual cells may be blank 
 
 
To use the List feature: 
• Click in any cell in the list. 
• From the Data menu select List, then Create List. 
• Confirm that in the List dialog box the correct data range has been selected and the 

“My list has headers” box is checked. 
• Click OK. 
 
A List toolbar will appear, AutoFilter boxes will appear in each column, and an Insert 
row, identified by an * in the leftmost column, will appear at the bottom of your list.. 
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To quickly add a Total Row to your list, click on the Total button    in the List 
toolbar. 



 
To add another row of data to your list, enter the data in the Insert row at the bottom of 
the list.  Alternatively, to insert or delete a row, click on the List button in the List toolbar 
and select Insert or Delete from the menu. 
 
To sort your data, click on the List button in the List toolbar and select Sort from the 
menu. 
 
 
Subtotals 
Using the Subtotal feature you can obtain subtotals within a column.  You can also obtain 
counts, sums, averages, and other statistics. 
 

• Be sure that there are no blank rows in your data. 
• Click on any cell within your data table. 
• Sort the data in the desired order. 
• Click on Data >Subtotal . The Subtotal dialog box will appear (see Figure 4). 
• At each change in:  Select the column within which you want the subtotals to 

appear  
• Use function:  Select the statistical function  
• Add subtotal to:  Select the field to which the statistical function is to be applied.  

Of course, the field must contain numerical values. 
• Click OK. 
• To remove the subtotals, click on Data  > Subtotals, then click on Remove All. 

 
: 
Example:   
You want to obtain the average annual salary for each job title in your list of employees.  
• Sort the data by job title. 
• Click on Data>Subtitles and select the following:  

o At each change in:  Job Title 
o Use function:  Average 
o Add Subtotal to:  Annual salary 

• Click OK. 
Beneath each set of identical job titles, Excel will add a (temporary) row that contains the 
average annual salary for that job title. 
To remove the subtotals, click on Data >Subtotals, then click on Remove All. 
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Figure 4 
 
Subtotal Views 
When you apply the Subtotal feature, you will notice that Excel adds three columns at the 
far left of your worksheet, labeled 1, 2 and 3 (See Figure 5 below).  By clicking on the 
numbers, you can control the amount of detailed information displayed in your 
worksheet. 
 
When you use the Subtotal feature, by default all three columns will be displayed.  These 
contain all the detailed rows of data as well as the subtotal rows. 
 
To display only the subtotal rows, click on 2. 
 
To display only a grand total, click on 1. 
 
To re-display all the detail rows, click on 3. 
 
 
To remove the subtotals, click on Data >Subtotals, then click on Remove All. 
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Figure 5 

 
Comments 
 
It is always a good idea to document your worksheet, particularly if it will be used by 
others.  The Comment feature is useful for adding explanatory notes to a spreadsheet. 
 
• Click in the cell you want to explain. 
• From the Insert menu, select Comments.  A text box will open, displaying the name 

of the person to whom the software is registered. 
• Click in the text box and type in your comment. 
• Click outside the text box to close it. 
• A red arrowhead will appear in the upper right corner of the cell.  When you point 

your mouse to it, the comment will appear. 
 
Enter Data in Multiple Worksheets at Once 
If you create the same worksheet each month or each semester, you can save time by 
entering the title, column and row headings and formatting in all of these worksheets at 
the same time, using the Group feature. 
 
• In a workbook create any additional worksheets you may need by selecting 

Worksheet from the Insert menu. 
• Click the tab for the first worksheet, hold down the SHIFT key and click the tabs of 

the remaining sheets.  Notice that [Group] will appear in the title bar of the workbook 
window. 
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• Enter the data in the first worksheet.  It will automatically appear in all of the grouped 
worksheets. 



• When you have finished entering the information common to all the worksheets, 
ungroup them by right-clicking on a worksheet tab and selecting Ungroup.Sheets. 

• Name a worksheet: 
o Double-click on the sheet tab 
o Type the name 
o Click elsewhere on the worksheet  

• To easily identify a worksheet, apply a color border: 
o Right-click on the sheet tab 
o Select Tab Color 
o Click on the color you prefer 
o Click OK 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Linda Perrotto 

 13 

September 2005 


